Website Issues

donsak's picture

Forums: 

There isn't a thread to post website issues so I am placing it  here.  When I see the list of topics it will show a number with NEW attached.  I click on it and it takes me to that thread.  Once there I am finding many posts that are not really posts and have no replies. There are many posts that say this topic has been moved. The website needs to be monitored for this and cleaned up to make it  more user friendly.  I am trying to use LOBO-Live as much as possible but it is difficult.

 

 

webmaster's picture

Hi Don.

Hi Don.

Thanks for the heads-up. I'll investigate and see what can be done.

Regards,
DJ Molny, LOBO Webmaster

webmaster's picture

OK, I think the problem is

OK, I think the problem is fixed. Please let me know if it recurs, or if you see any additional issues!

For anyone interested in the details:

  • The LOBO web site is built atop a "content management system" called Drupal which includes the forum module that powers LOBO Live!.
  • I added the "forum subscription" feature that lets users can control the email notifications for new content, from any or all the different forum topics.
  • The built-in forum module considers any site page that connects to the forum topics -- including those subscription records -- to be a forum post and adds it to the list of posts for that topic. Thus, if a user sets up their forum subscription and says they want to receive notifications for topics X, Y,  and Z, it suddenly looks like there are new posts in topics X, Y, and Z -- all of which say "this topic has been moved".
  • I coded a fix for this problem when LOBO Live! was unveiled, but a subsequent update of the Drupal software unexpectedly overwrote my changes. Re-applying those changes seems to have done the trick.

Thanks DJ and thank you, Don,

Thanks DJ and thank you, Don, for pointing that out I was going to do the same, as those irrelevant posts were clogging up the threads just as traffic has increased on this site. I am happy to see more posts and hope we can all make LOBOLive useful and engaging!

I also am hoping that the use

I also am hoping that the use of the forum can be made better and appreciate the recent cleanup.  There appears to be an issue still related to finding new posts in order to read them and having the top level forum list update to reflect that all have been read.

Specifically, I tried to read everything marked new and then refreshed the forum list.  The word "new" still, sometimes, appeared there.  Sometimes it updates to fewer new items but still more than zero.

A closer look might explain some of this.  The forum list says there are x number of topics on the lower level page but when I go there, there are sometimes more or fewer actually listed:

Events                 Claims 14 but only 9 visible.
Insurance            Claims   3 but there are 4 visible.  The newest has 8 replies
Training               Claims   8 but there are only 6 visible.
Airframe              Claims   9 but there are only 8 visible.
235/320/360        Claims 13 but there are only 12 visible.
IV Series             Claims  11 but there are only 8 visible.
Evolution             Claims  13 but there are only 6 visible.
 

No where do I see a "next" button to move on to a different page on those that have the above mismatch.  Events, Training, IV Series, and  Evolution all show "new" topics on the top page but I can't seem to get to those.

All in all though we are getting closer and closer to having a well oiled machine!

Thx for all the help DJ

webmaster's picture

Hi Tom, and thanks for that

Hi Tom, and thanks for that info.

That may be another side effect of the forum module mistaking subscriptions for posts. I'll talk to the LOBO brass and see where this falls on the priority scale.

Regards,
DJ

Tom

Tom

Thanks for finding these anomalies. I may be guilty of some of the discrepancies, at least in the Events heading. It takes a bit of noticing to put your new topic under the proper category and a lot of "Event" postings early on were really posts on other subjects because "Events" was the top choice. I moved some users' posts to Training or Insurance...maybe doing that didn't reset a counter of some sort on the site. I know just enough to make a mess on here. Adding the "General" category has helped and as folks get more familiar with the system, they are selecting an appropriate category for their new topic.....

We have a way to go and your feedback is much appreciated.

 

donsak's picture

The list of topics keeps

The list of topics keeps showing some of them as having new posts days after I have read them.  I refreshed the page, closed it, opened it again with the same issue.

webmaster's picture

Hi Don.

Hi Don.

After some research, I've found that the problem with "New" icons is yet another manifestation of the system treating forum subscriptions as if they were forum posts (see above).

I was unable to devote any time to the LOBO site over the past few weeks due to a major software release for another customer. However, LOBO issues are now back on the front burner and I hope to deal with this one problem -- and its many side effects -- shortly.

We'll see if a separate category for website / forum issues is warranted based on future traffic. In the meantime, feel free to post here if you think something is of general interest, or you contact me directly via email at dj [at] lancairowners.com, or use the site's Contact page.

Regards,
DJ Molny, LOBO Webmaster

donsak's picture

For the past week the LOBO

For the past week the LOBO Live has shown me 1 new post in the Engine thread and 5 new posts in the Evolution thread.  I’ve read each one, closed the page, closed the website, shut down and logged in again.  I still have the same showings.

webmaster's picture

Hi Don.

Hi Don.

After evaluating several approaches to fixing the problem, I finally hit on a simple solution and put it in place a few days ago. The forum subscriptions that used to show up as "ant" topics, or "moved to another group" are no longer visible. And the system now displays the correct number of unread items in each topic, if any.

-- DJ

DJ, any way we can add the

DJ, any way we can add the Tapatalk script into the website hosting code? I've helped a few other forums add the capability and it makes the site much more accessable for those using mobile platforms.

Ryan

 

webmaster's picture

Hi Ryan.

Hi Ryan.

I did some research but didn't find any info about how Tapatalk integrates with existing web sites. If you don't mind, please contact me via email -- dj [at] lancairowners.com -- so I can learn about your experience with it.

Thanks,
DJ